CSV opened in Excel - all data in one column

Hi Kate,

Why is CBT exporting the .csv into one column in excel?

Cheers and thanks,


Hi Gerhard

This is not a CyberTracker issue, but an Excel issue. Your Excel is not recognising the commas in the CSV as separators.

You have two options:

  1. In Excel, import the data from the CSV instead of just double-clicking the CSV to open.
  2. Change your system settings so that Excel will recognise the separator always.

Import data

  1. Open Excel.
  2. In the Data menu, choose From Text/CSV.
  3. Browse for your CSV file.
  4. When the preview of your data opens, make sure it is split into columns. If not, make sure the Delimitor is set to Comma.
  5. Press Load.

Changing your settings

From this article:

The behavior of Excel when opening CSV files heavily depends on your local settings and the used list separator under Region and language » Formats » Advanced . By default Excel will assume every CSV was saved with that separator.

The list separator should be set as a comma.

Not sure what version of Windows (are you using Windows?) you have, in Windows 10 you need to go through the old Control Panel (press Start and type Control Panel).

Kind regards, Kate

The settings on my laptop are exactly as instructed, but it doesn’t help. I finally had some success using this website How to correctly open exported CSV files in Excel, but all information from “notes” screens in CBT ends up in other columns. I suppose I can copy and paste it manually, but is there another solution?

Hi Gerhard
I suspect your notes possibly have commas within them, or some other character that excel is interpreting as a separator, and so they are being split into other columns.
Please could you try the Import data option in Excel and see how that works for you?
Kind regards, Kate