Database size is inexplicably increasing


My MDB file seems to keep growing each time I do something with it . Now its at 598 MB. Strangely the size of the file that is transferred for web update is manageable small and not increasing (116 mb).

I cannot work out why this is happening. I cannot find anything in the system files, export media or anywhere else I can think of. This is not a problem for those who upload and use the project but It becoming a problem for editing the application because it is now taking several minutes to save the file and it frequently freezes.

Any ideas?


Sydney, Australia

Dr. Eren Turak

Principal Scientist Biodiversity Research and Assessment NSW Department of Planning, Industry and the Environment

4 Parramatta Square, Parramatta 2150 NSW

Co- chair, Freshwater Biodiversity Observation Network (FWBON)

Tel: (02)99955506 Email:

I know, big mdb’s are hard to handle.
Can you explain what it means: " … each time I do something with it "? I think you know that all sightings are inside the mdb-File. And in case of big Media (Photo, Audio-Records) it will increase very fast.

my hints:
From time to time I use “Tools->pack database”. But it decreases my mdb only little.
The other idea I use is: “Save as …” from time to time for achieving the sightings and delete all sightings in the original mdb.
You can also export the media with “Reports->Query->Export View as CSV”. Than all the photos are in ExportMedia-Folder and than you can delete the photos in mdb.

I hope, something helps.

Holger, Germany

Hi guys,

It is possible to have CyberTracker be very responsive even if the MDB is very large.

Some guidelines:

  1. Use the “Image” Control sparingly. Instead, prefer to put your image inside an Element and use the “Element Image” control instead. This will make it fast to load and save when all you have changed is a Screen.
  2. Avoid use the “Date range=All” in Reports while showing a Map View if you have many track points. Set the “Date range” in the Inspector to just the range you need.
  3. Avoid using the Table View column filters for date range
  4. Avoid multiple open Map Views at the same time when there are lots of track points.
  5. Under File->Database properties->Advanced, make sure “Change tracking” is unchecked
  6. Consider snapshotting your database by year, i.e. at the start of each new year, create a copy of the database and remove all the data. You can do this using:
  7. File->Export CTX->Export Database
  8. Set the Date Range to a day without any data
  9. Open the resulting CTX and save it as a new MDB file – this will be your database, but without any data in it1. Consider moving to a bigger database, e.g. Microsoft SQL Server



Thanks a million for the quick response Justin and Holger

Two simple steps did the trick