CTX file to big to open it with CT

Hi there,

We got a very big CTX file (~2GB) due to a large amount of photos on it. I’m trying to directly open it with Cybertracker of import it to an empty CT database but with no success. I’m continuously get the message of (something like that) “not enough memory available to run the file”. I’ve also tried to allocate more memory to Cybertracker, 8GB, but still not able to open the file. There is any way to split the file in several smaller ones? I’m running the windows 8 64bits with 16GB RAM, so should be enough to open a file like this.

If someone can give a try to open it, I really would appreciate. The file is available here https://drive.google.com/file/d/1hpYtnFsYmdOmjjLRC_rRIjjtzDSyNfBI/view?usp=sharing.

Nuno Oliveira

The trouble is that CyberTracker is a 32-bit app, which means it can never use more than 2Gb of memory. I think the only way around this is to ask them to send you smaller date ranges when they do the export.



CTX is a container and inside is the big file of sightings.dat. PilotEditLight.exe is an free editor which is able to handle files until 10GB. The sightings.dat can be opened with (need some minutes.) If it would be possible to cut the big file in smaller ones. may be it would help. @Justin, in which format are the data inside sightings.dat (xml, html, json, sql, …)?


Unfortunately, it is a binary format. However, it is chunk based, so we could find the right point to split it into multiple files.

If you share the file with me, I will see if I can split it apart.



Justin, this editor hast also HEX-Mode and the Link to the file from Nuno is above.
Cheers from cold weather in Germany

PS: Justin: I cut the file in two parts (around 1GByte), packed in .cab and rename in .ctx … import started but I saw nothing. Maybe I need the project too? (Or the cut was wrong…), Holger

I’ve checked my tailored file with the right project from Nuno, but import breaks without showing results. I guess my file is not ok. Sorry. :frowning:

The main file that is about 2GB is broken. The maximum size for a CTX/CAB is 2GB and this is right at the limit. My guess is that the export continued until it failed and this was the remaining file.

The smaller file (…MAP_INVASIVES_TEMP.CTX) looks fine to me, but the sightings are all marked as deleted. These can be recovered if that would help.



Thanks Justin. The second file is only an empty Database as Holger asked. So do you mean we cannot recover any data from the 2GB file? Uff. It is a lot of data that we really need.


A quinta, 22/04/2021, 19:09, Justin Steventon <justin@steventon.com> escreveu:

Is it possible to re-export, but use a series of smaller date ranges?

If this is using MySQL, then you should be able to backup the entire database to a file as well.



How can I re-export using such series of smaller date ranges?

A quinta, 22/04/2021, 23:45, Justin Steventon <justin@steventon.com> escreveu:

When you use the File->Export to CTX file->Export Data option then you are asked for a date range. I would try doing a single year at a time and see how big the files get.



But to do that, first I should be able to open the file, shouldn’t I?


A sexta, 23/04/2021, 17:15, Justin Steventon <justin@steventon.com> escreveu:

It needs to be done from the machine which generated the CTX to begin with. Is that still available?

Do you mean the device from where data was recorded?

A sexta, 23/04/2021, 22:23, Justin Steventon <justin@steventon.com> escreveu:

No, the desktop computer which exported the big CTX in the first place.

The big file I shared with you is the one created by the device from where data was acquired, and then sent for our ftp server. From there, I was not able to open it in the desktop computer.

A segunda, 26/04/2021, 05:11, Justin Steventon <justin@steventon.com> escreveu:

Ah, so if the file came from a single phone, then something must have gone horribly wrong, because this is just way too large. Can you confirm how much data you were expecting?